search-icon

Scheduled Reports - report templates not saving

started a topic about 1 month ago

I have discovered a simple issue with the Scheduled Reports which seems to be purely based on poor logic:


In Reports > Inventory Reports > Products Stock Level, I have set up a template with a daily stock-on-hand report for a particular warehouse location. In the report template itself, the option to select 'Non-Zero Qtys only' is selected and it appears to save to the Report template.


However when I used this report template in Automation > Scheduled Reports, the specific 'Non-Zero Qtys only' setting doesn't seem to translate across - therefore the scheduled report contains every single SKU regardless if it's on hand or not.  This specific scheduled report is for a secondary location where we only hold less than 100 SKUs on hand, whereas the Excel report on the scheduled email list all active SKUs (4300+), forcing the user to play around with the report data to make it meaningful (on a daily basis).


I can't see where the logic is to exclude the 'Non-Zero Qtys only' , so Im suggesting it should be a  simple fix that is implemented ASAP.



image



2 people like this idea
  • We are also having this issue! The Automation for scheduled reports does not save the filters and settings that you have built out for your custom report that you want to save and schedule.


    What is the point of payment for the automation module when it does not work properly. They need to fix this ASAP as its a major flaw in the reporting functionality.

  • Hey Michael, great to hear you feel the pain too, hopefully DEAR can recognise this and do something about it.


    Just on the filters - I did have a bit of trouble getting the Custom Filter / PivotGrid settings to 'stick' initially - it was just a bit glitchy. I worked out you kind of have to add a blank condition at the end of any of the others before it will save to the Settings. Then go back, delete the last blank condition and save again as another report.

    Very tedious, less than satisfactory (should be another Feature Request), but at least I did manage to work around that one.... 

Login or Signup to post a comment

2 people like this idea
Log in or Sign up to post a comment